[plug] [PLUG] sed will not

David Campbell campbell at torque.net
Thu Oct 29 10:23:23 WST 1998

Date sent:      	Wed, 28 Oct 1998 23:28:42 +0800
From:           	Navarre <navarre at omen.net.au>
To:             	"plug at linux.org.au" <plug at linux.org.au>
Subject:        	[plug] [PLUG] sed will not
Send reply to:  	plug at linux.org.au

> Hello All
> I wished to perform a simple operation using sed to search for the
> string
> GAWK(1)^I
> as the output of cat -A gawk.txt will show.
> What I wished to do was, search for the string GAWK(1) and the following
> tab and replace it with a form feed character, the string Gawk(1) and
> the tab character. 
> I tried using sed 's/GAWK(1)\11/\14Gawk(1)\11/' gawk.txt
> This did not match any lines in the file.

You don't need the \11, an imbedded tab would of worked.
> Also is there a form of hex dump program like the ones found in the
> CP/M  world.

Every addict should know this one: "od"
You will need a few flag options since the default is an octal dump.

David Campbell
campbell at torque.net

Current project list:
a) Maintain Linux ZIP drivers (documentation needed)
b) Create Linux chipset specific parport drivers

Any assistance to clearing this list most welcome

More information about the plug mailing list