[plug] Slow Serial Port

Linux squirrel at emerge.net.au
Mon Apr 23 20:15:55 WST 2001

Hi all 
I have a problem that I have not been able to resolve and need some help please
I have been trying to fix this for months

The problem is my second serial port ttyS1 seems to get hung up almost like it has a irq problem.
I can dial into my modem on ttyS0 and there is no problem 
When I dial into ttyS1 I get 45%-90% packet loss pings are 140/ms

Things I have done or know and have made no difference
System RedHat 6.1 Kernal 2.2.12-20
The modems on both ports are Identical and have been swaped 
I have tried disabling the second onboard serial port and fitted a serial i/o card and tried all possable irq settings i/e 3-4-5
I have disabled the mouse GPM
I have changed motherboards and CPU
I have used setserial and tried lots of combinations
Useing ttyS1 as the dial out port yeilds the same results (huge packet loss)
Cables and phone lines have been checked and swaped.
Modem initilizes correctly and has no problem answering 
I changed from mgetty to Radius & Portslave

There must be something I have missed or can do 
Any help would be greatly appreciated
Regards Bob Andrews

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20010423/4e56d413/attachment.html>

More information about the plug mailing list