[plug] smb client timeout problem - FIXED

Craig Ringer craig at postnewspapers.com.au
Tue Nov 15 14:58:56 WST 2005

Steve Boak wrote:

>On Tue, 15 Nov 2005 01:35 am, Ian Kent wrote:
>>>(Note that all my tests were done with at least kernel 2.6.13, Samba
>>>3.0.20b, and Debian Testing on both machines)
>>>Linux client	mount -t cifs ...	shares from Samba server
>>>Linux client	mount -t smbfs ...	shares from Windows-2000
>>>Windows client	uses smbfs?	shares from Samba server
>>Interesting to see that this is still a problem in 2.6.13.
>>Have you tried 2.6.14?
>share 'tmp' is on 'shuttle', a win2000-pro desktop, 'min' is the Linux client:
>min:/home/steve$ uname -a
>Linux min #1 PREEMPT Fri Nov 11 23:19:55 WST 2005 i686 GNU/Linux
>min:/home/steve$ mount -t cifs -o username=steve //shuttle/tmp /mnt/tmp
>mount error: could not find target server. TCP name shuttle/tmp not found
>No ip address specified and hostname not found
Odd that it appears to be trying to resolve the name 'shuttle/tmp' . 
Have you tried:

mount -t cifs -o user=steve '\\shuttle\tmp' /mnt/tmp


Note that according to `man mount.cifs' the user name is specified as 
user= not username= (though if you use a credentials file, it contains 
username= ... weird ).

Also, have you tried a DNS-based or IP-based UNC path like 
'\\shuttle.localnet\tmp' or '\\\tmp' ?

>I didn't test any further as I can do all I want with either smbfs or cifs, 
>depending on whether I want to connect to windows or Samba shares 
The kernel folks seem to be planning on yanking smbfs real soon now, so 
I'd strongly recommend reporting problems sooner rather than later.

Hm, that reminds me, I still need to test to see if the latest version 
of cifs (with "legacy server support") will talk to the NT4 at work.

Craig Ringer

More information about the plug mailing list