[plug] Upgrade fc4 to fc6

Tim Bowden tim.bowden at westnet.com.au
Thu Apr 26 10:34:20 WST 2007

Hi all,

I recently tried to update a friends fc4 server (neglected in the update
department for quite some time).  The primary aim was to get it to fc6.

When I ran yum update (with the intention of bringing it up to the
latest in fc4) I got a number of missing dependencies and a partly
broken system.  I could no longer log in remotely, and my friend could
no longer log in locally.  Samba and apache were still working (so for
the time being all was not lost as its primary purpose was as a web
server). yum.conf looked to be in its original state (from memory, as I
can't get in to look anymore).  Is this sort of behaviour to be expected
from an unmaintained fc4 system?  I was assuming the behaviour would
follow the debian model, ie, if an upgrade doesn't work, back out

Given that I'm now pursuing option 2 (build a CentOS system on a spare
disk, restore web sites from backup and swap it in later) I no longer
need to fix it, but just for the record, can anyone tell me what
procedure I should have used?  In hindsight, I should have asked here

Tim Bowden
Mapforge Geospatial
Level 3, 267 St Georges Tce
Perth, 6000
Western Australia
Ph: 08 9261 7780
Fax: 08 9261 7700
Mob: 04 2316 7272

More information about the plug mailing list