[plug] partition image

Bernd Felsche bernie at innovative.iinet.net.au
Tue Mar 6 12:13:38 WST 2007

Jim Householder <nofixed at westnet.com.au> writes:
>Jim Householder wrote:

>> dd has made a copy on my FC6 drive, but cannot restore it.

>> data# ls -al
>> ...
>> -rw-r--r--  1 root  root  2167570944 Mar  5 17:55 winme-fresh.image
>> data# dd if=winme-fresh.image of=/dev/sda
>> dd: writing to `/dev/sda': No space left on device
>> 1034609+0 records in
>> 1034608+0 records out
>> 529719296 bytes (530 MB) copied, 10.8999 seconds, 48.6 MB/s
>> I get the same result using /dev/sda1 as a destination.
>> The copy speed of the original was 1 MB/s, so 48.6 indicates the 
>> destination is not right.  Also the 530 MB space limit.  Nothing on the 
>> system appears to correspond to that space.

$ cat /proc/scsi/scsi

>I was looking for the wrong thing.  What I need is a *disk* image, not a 
>partition image.  I think I've found what I need.

>Still curious as to why dd did not behave as expected though.

Because you tried to copy a 2GB (suspiciously close to 32-bit
pointer limit) image to a 530MB disc. You don't happen to have USB
storage of sorts plugged in?

If sda is a real SCSI hard disc, then check it for errors.

Also, when copying hard disk or partition images, use a *larger*
block size. At least 64k... 1024k if your system tolerates it.
That reduces the system overheads because there will be fewer calls
to the operating system.
/"\ Bernd Felsche - Innovative Reckoning, Perth, Western Australia
\ /  ASCII ribbon campaign | "If we let things terrify us,
 X   against HTML mail     |  life will not be worth living."
/ \  and postings          | Lucius Annaeus Seneca, c. 4BC - 65AD.

More information about the plug mailing list