[plug] trying to share internet - seems hopeless

Tomasz Grzegurzko tomasz89 at gmail.com
Mon Oct 22 09:53:10 WST 2007

On 10/22/07, Coral and Ben <cobel at bigpond.com> wrote:
> Hi there pluggians,
> I am running kubuntu 7.04 with kernel 2.6.17-50-generic (not the
> standard kernel - the std one labels some IDE dvd/cdroms as scsi devices
> and tries to control them as such - some kind of sideways step in kernel
> development probably designed to be more compatible with sata drives but
> you end up with unusable ide devices), and I have bigpond wireless
> broadband with the blue desktop modem.
> I have fantastic reception since installing a car antenna to the outside
> of my house (without the antenna I get scanty intermittent reception)
> and the modem seems to work fine in linux, being assigned a dynamic IP
> and the device label ppp0 once it is 'dialed' and connected. While it is
> not in use it does not exist - ifconfig doesnt list it.
> I really need to share this connection around the house, my computer has
> a working wireless adapter (eth1), my daughters kubuntu machine (7.04,
> standard kernel) has a working wireless adapter, and my husband has a
> windows laptop with a working everything (including wireless and blutooth)
> I also have two wireless routers, a plain one with wireless, ethernet
> and a wan link (this one doesnt want to work without internet detected
> at its wan port however), the other one is an asus wl-500g premium, it
> has the same features as above plus two usb ports for attaching network
> devices like HDD's and webcam's, this one is supposed to be able to take
> new firmware and is listed as compatible with openwrt and dd-wrt both of
> which are supposed to make it able to dial the modem when correctly
> configured (these two firmware versions are essentially mini-linux distros)
> my computer also has working ethernet (eth0), but when it is active the
> ppp0 interface is bumped from its position as internet gateway, and will
> not be reinstated no matter how hard I try
> ifconfig:
> eth1      Link encap:Ethernet  HWaddr 00:02:72:63:0F:B5
>           UP BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
> lo        Link encap:Local Loopback
>           inet addr:  Mask:
>           inet6 addr: ::1/128 Scope:Host
>           UP LOOPBACK RUNNING  MTU:16436  Metric:1
>           RX packets:115012 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:115012 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
>           RX bytes:8968550 (8.5 MiB)  TX bytes:8968550 (8.5 MiB)
> ppp0      Link encap:Point-to-Point Protocol
>           inet addr:  P-t-P:  Mask:
>           RX packets:2826 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:2929 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:3
>           RX bytes:1380590 (1.3 MiB)  TX bytes:305747 (298.5 KiB)
> *eth0 is deactivated
> I have tried the ubuntu forum but only got a couple of obvious (and not
> really helpful) responses and no recent replies to my posts there
> I have guidedog installed (supposed to be an easy nat/masquerade thing -
> but  without help I don't get that either) I have guarddog - iptables
> frontend and I have tried to use firestarter (also an iptables frontend
> but, has a very easy way to share internet built in) but that hangs when
> it starts, with no error messages.
> some other oddities:
> interface lo does not start at boot I have to start it with "ifconfig lo
> up", I have noticed that I often have another interface eth1:avah in
> ifconfig also, that disapears once I stop and restart eth1
> also I have working bluthooth, could I share internet that way?
> sorry to be so wordy, but this has been going on for quite a while now.
> as a side note this internet connection cannot be easily shared in
> windows either, but with some stuffing around, I have shared it the
> windows way before, but this computer is quite new - it came with
> windows which I hung on to briefly until I worked out how to use this
> modem with linux, then i reformatted and now have only linux.
> well, thanks in advance
> Coral
> _______________________________________________

The only thing I've ever needed for such set ups is here:

Specifically the "hardened iptables script" is of great use; make sure
your custom kernel has IPTables support enabled and all it's features
and subfeatures, modify the variables at the top of the script
(external ppp0 in your case, internal eth1) set your IP addresses,
etc, and off you go.


More information about the plug mailing list