[plug] new kernels don't like scsi controller

Richard Meyer meyerri at westnet.com.au
Tue Apr 1 15:57:43 WST 2008

You did say that a power surge broke the machine and you've been
replacing components - perhaps the power surge let the magic smoke out
of the SCSI controller as well.

Bummer, I know .....

On Tue, 2008-04-01 at 15:52 +0800, Gavin Chester wrote:
> I have wrestled with installing the latest kernels on my workstation for
> a couple of days until finally pinning the issue down to the LSI u320
> pci-x dual-channel scsi controller. 
> Not sure how much detail to give without getting writer's cramp and
> boring you all to tears, versus being obscure about the cause. Suffice
> to say, perhaps, that this controller worked fine within this PC system
> using FC5 and opensuse10.1 until a power surge caused it to bork some
> months ago. I'm now replacing bad components and have been trying to
> reinstall with an upgrade to opensuse10.3. 
> The first few times os install failed I tried alternative distros in the
> form of the latest ubuntu, kubuntu, xubuntu (I know they're basically
> the same), centos 5, et al. None of these worked, they would jsut freeze
> before getting too far into the install. Opensuse10.3 was the most
> informative, showing that it was failing jsut after hardware detection
> and hald had started. The message on the console was "starting syslogd
> (logging to /dev/tty4) ..." and there it sat forever. Common with all
> distros at this point was that the keyboard had failed, too (though
> active up to this point).
> Thinking maybe the nVidia FX1000 pci-e card was a problem, I swapped in
> an older pci graphics card, but same fault. It was only when I removed
> the lsi pci-x u320 scsi card and replaced it with an older adaptec pci
> u160 card that the system continued into allowing os install. Weird. The
> lsi card had worked with older distros/kernels.
> What I'm hoping from you good people is some leads as to why this might
> be happening, and confirmation that swapping back in the lsi scsi card
> after os install will work.
> BTW: I flashed the mb bios but made no difference
> Gavin.         
> _______________________________________________
> PLUG discussion list: plug at plug.org.au
> http://www.plug.org.au/mailman/listinfo/plug
> Committee e-mail: committee at plug.linux.org.au
Richard Meyer
Necessity is the plea for every infringement of human freedom.
It is the argument of tyrants; it is the creed of slaves. 
William Pitt, 1783

Linux Counter user #306629

More information about the plug mailing list