[plug] Postfix problem...maybe?

skribe productions skribeproductions at gmail.com
Thu Apr 10 08:47:45 WST 2008

Hey folks:

Thanks to Michael, Lance and Craig for helping me before.  Now I have a new
problem.  For some reason postfix is playing silly buggers and I can't work
out why.  Sending from gmail to my machine I get this error:

This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

     recipient at domain1.com

Technical details of permanent failure:
PERM_FAILURE: Gmail tried to deliver your message, but it was rejected by
the recipient domain. The error that the other server returned was: 554 554
<recipient at domain1.com>: Recipient address rejected: Access denied. We
recommend contacting the other email provider for further information about
the cause of this error. Thanks for your continued support. (state 14)

I've tried playing around with the mydestination setting in main.cf but for
some reason I can never get mail being delivered to all my domains, and
never to the machine's address ($myhostname in postfix). ie.  Sometimes the
mail is delivered for domain2.com and sometimes for domain2.com and
domain3.com, but never for domain1.com.  I'm no longer receiving internal
mails (ie logcheck) either.

Any suggestions?


--- main.cf --
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = amber.com.au
mydestination = $myhostname, localhost.$mydomain, domain1.com,
www.domain1.com, mail.domain1.com, domain2, www.domain2.com,
mail.domain2.com, domain3.com, localhost
mynetworks =,, x.x.x.x/32
mailbox_size_limit = 0
recipient_delimiter = +
mailbox_command = /usr/bin/procmail
smtpd_recipient_restrictions = permit_mynetworks reject_unauth_destination
relay_domains = $mydestination
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20080410/34ebfa06/attachment.html>

More information about the plug mailing list