[plug] PS3, MediaTomb occasional freeze in video stream

Lucas van Staden lvs at dedmeet.com
Thu Feb 19 22:33:18 WST 2009

Daniel Pittman wrote:
> Lucas van Staden <lvs at dedmeet.com> writes:
>> I use MediaTomb on an epia machine, running debian, as my media/file
>> server to my PS3.  When watching divx video, the stream pauses every
>> now and then, and I can't see any pattern, it seems random.
> Hmmm.  I will be very interested to hear what the outcome of this is,
> since I am considering ending up with a similar configuration — modulo a
> much more powerful server, sitting further away. ;)
> In general, are you happy with the system?
Yes I am. Apart from this glitch, playback is smooth.

However the PS3 control panel is cumbersome.
I much prefer mythtv's interface, but my via box is really dated, and it 
is time to upgrade to enable HD viewing.
As I already have the PS3, I figured I will use it, and my wife (for 
some unknown reason) prefer the PS3 interface.
Also it makes me feel I am getting my monies worth, as I find I am 
playing less and less games, and using it more and more as just a BD player.

When you setup mediatomb, you must check the wiki, and use one of the 
import.js configurations that split your files alphabetically, or else 
it becomes a nightmware to get to the file you want (my main gripe with 
the interface)
You may also be interested in my 'movie poster' setup here 
It allows you to push movie posters found on IMDB to the PS3, which 
makes the listings of the files look nicer.

As mentioned, the via box used to run mythtv (in fact it is still a full 
mythtv frontend), but I never used mythtv's tv capabilities - I just 
used it as an easy interface to my video files, which the PS3 is doing 
just as well.

I am in the process of installing a new system from scratch (using 
deboostrap), onto a compact flash module.
I am now waiting for the CF -> IDE adaptor to arrive. This will be a 
minimal install, under 256mb, and I am hoping that this new install will 
sort out the freeze glicth.
The via board will be installed into a new enclosure, with no drives, so 
it will in effect become a NAS with mediatomb installed.

I tried using the PS3 over the wireless, g-network, but the wireless is 
just too slow. MANY freezes/timeouts, and you cannot ffwd/rewind nicely 
- it jumps frames massively.
I now have the PS3 connected to the via box, and the via box is doing 
nat for it, so I can still access online content using the PS3.

I am not happy with the PS3's music interface. I am yet to find a way to 
select a folder, and play all files in the folder (folder as in 
mediatomb folder served)
Seems you can only select individual files, and play each one manually.

The PS3 can really do with a next-gen style of player, as the cumbersome 
interface makes finding your music really a hassle.

>> The obvious move was to ssh to the box, and monitor it using top, to
>> see if there is a process that takes up cpu resources, thus causing
>> the pause.
>> The only thing is, once I ssh in, and I run top, no pause (processor
>> never drops below 70%) . So it would seem that running top solves the
>> issue, but it is a silly resolution to solve the issue.
> That is interesting.
>> Any ideas? Possibly other ways to monitor system resources?
> Well, I would try vmstat or dstat running detached on the machine,
> probably under screen, so I could disconnect the ssh session.
> That should give you nice monitoring, especially logged to a file,
> without ssh peturbing things.  If it still makes things work you have
> trouble. ;)
>> I did set the hard drive not to sleep/spin down, but that has not
>> solved the issue - still need top running.
> Any kernel messages around the same time?
> How about logs: is cron kicking off a background process?
I think (hope) that was it - found that a cron job for php ran when it 
froze, and also NTPD update

Feb 19 21:38:22 midgy -- MARK --
Feb 19 21:39:01 midgy /USR/SBIN/CRON[7062]: (root) CMD (  [ -x 
/usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find 
/var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | 
xargs -n 200 -
Feb 19 21:45:50 midgy ntpd[2421]: kernel time sync status change 4001
I disabled cron, and ntp now, and am waiting for the next viewing run, 
to see if I get more freezes.

Strange still, that the freeze did not occur during top, as there are 
log entries for that time of my viewing.

>> Oh yeah - the two are directly connected via a cross-over cable, on a
>> gigabit connection, so I don't think it is a network issue (upgraded
>> the network on the epia previously, as I thought that the 100mb
>> network may have been the issue)
> My guess would be not, but it might be worth checking for errors on the
> interface or possibly a tcpdump.
I agree, I don't think the 100mb network had anything to do with it, but 
the 1gb network link will not hurt.
In fact, the file thumbnails appear near instant now on the PS3, so that 
did help. On the 100mb link some sometimes did not even show.
This may again be due to my slower epia box, or a combination of slow 
epia (950mhz) and slower network, as I have found that the PS3 sends a 
multitude of requests for the thumbnails in one go, thus some timed out 
getting back in time.

> Regards,
>         Daniel
> _______________________________________________
> PLUG discussion list: plug at plug.org.au
> http://www.plug.org.au/mailman/listinfo/plug
> Committee e-mail: committee at plug.linux.org.au

More information about the plug mailing list