[plug] Help needed ...

David Dartnall darts at dialix.com.au
Sun Jul 18 12:44:01 WST 2010

On 15/07/10 22:15, Peter wrote:
> On 15/07/10 21:35, Richard Meyer wrote:
>> Advice, I have plenty of, AND AT NO EXTRA charge...  ;-)
>> I would check the bios startup messages for any SMART info about the WD
>> disk.
>> If there were messages about how broken it was, I'd weep.
>> What I would then do (regardless of SMART results), is lash out for a
>> USB disk cage/enclosure for about $20 and put the disk in there.
>> I would then boot without it and plug it in, and see whether Linux can
>> see it ....
>> I would also run smartmon against it .. (Hmmm, I don't have smartmon any
>> more) I'm sure others will have better ideas for disk diagnostics
>> anyway ...
>> If I could access the disk, I'd back up what I needed and
>> destroy/reformat the disk as indicated by the SMART status.
>> HTH

> Following on from what Richard said, if you can get the machine 
> running either with the disk in place or in a USB enclosure, you can 
> try some of the following:
> In a console do "fdisk -l" and/or "cfdisk /dev/???" where ??? is the 
> drive in question (eg.  sdc) to see if Linux can find the disk, even 
> if it doesn't recognise any partitions.
> If the above works,
> Run 'testdisk' (eg:  'sudo testdisk /dev/sdc' if using a ubuntu live 
> disk) in a console to see if there are any recoverable partitions. You 
> may have to install testdisk first as it is not included on a standard 
> ubuntu installation.     If testdisk finds any info on the drive 
> (there is a "view files" option that sometimes works even if the 
> partitions are corrupt.  You will need another disk (mounted 
> partition) to copy files to if it finds any.
> I'm three hours out of Perth, so can't offer much in the way of hands 
> on assistance, but may be able to talk you though some stuff if 
> required....
> If none of the above works....  If Linux can not see the drive at 
> all....  the disk may be dead, however if you can hear it spin up when 
> powered on and there is no significant noise (ticking?) then you may 
> have a faulty PCB.  The drive may be recoverable but requires 
> specialist knowledge.....  I can put you in touch with someone who may 
> be able to help, if the above options fail.  I recently recovered a 
> Drive with a fried PCB.  It took weeks to recover the data (long 
> story) but only cost me $50.00 in parts.
> Cheers,
> Peter

Thanks Richard but I can't access the disk.   fdisk and testdisk  don't 
find it either, Peter.

It proved to be getting power when the other two disks were disconnected 
and power switched on - it spun up, but with a slightly gravelly sound 
which settled down after a few seconds but the closest the system has 
come to recognising it was when I tried to mount it...

     "sudo mount /dev/sdc -t ext3 /mnt"    and got the response   "no 
medium found on /dev/sd3".

So there it is - a dead duck disk which I bought on 22nd of April 2009!

Is it worth taking it back to MCG Technology to see if they can do anything?
What can you at Linux It do Scott?
Do you think your guy might be better able to get access to it, Peter?

Dave Dartnall/

>> On Thu, 2010-07-15 at 21:08 +0800, David Dartnall wrote:
>>> Now that the plug server's up again, below is the third of three emails
>>> which didn't get through. Perhaps someone could advise/help.
>>> Hi all,
>>> I need a linux/hardware guru. My system suddenly refused to boot, and I
>>> took it to the Windows bloke who sold it to me and who has been keeping
>>> it going over a number of years, and he got Windows running.
>>> It has XP as well as Lucid on it, and the Windows drive now boots into
>>> Windows, (very slow if the Lucid disk is connected) but Windows systems
>>> can't see Linux disks, so I tried a Jaunty CD disk that I had but it
>>> would only fully boot into a live session if the drive holding the 
>>> Lucid
>>> system is disconnected.
>>> With it connected, (it's a relatively new WD 500 gig drive), the Jaunty
>>> live session boot stops after selection of the language 'English' and
>>> drops into a initramfs root prompt.
>>> Running the live session with WD 500 unplugged, gparted found the
>>> Windows disk and also my third disk which was formatted ext3 but 
>>> without
>>> any OS on it.
>>> I installed Jaunty on this and plugged the 500GB Lucid disk in and
>>> rebooted. After a _very long_ boot time, the Jaunty system comes up but
>>> all it can see is the Windows disk... Jaunty boots quickly with the
>>> 500Gb disk disconnected.
>>> It's obviously going to cost money but I need to get the Lucid system
>>> going - I'll take the box anywhere Perth Metro area...
>>> Regards and advice please.
>>> I am unable to access the WD 500GB Lucid disk - can not see it.
>>> No I have not backed up - I'll never learn!  I sure will now tho'.
>>> Regards
>>> Dave Dartnall

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20100718/8ebc000d/attachment.html>

More information about the plug mailing list