[plug] NFS Large File writing causing "freezes"

Tim weirdit at gmail.com
Sun Sep 26 17:50:48 WST 2010

NFS Large File writing causing "freezes"

I'm currently in the process of backing up a large number of DVD's (due to
children destroying DVD's) to the computer. The process was 2 machines
ripping directly to one of the machines hard drives, and a cluster of
machines encoding from that machines hard drive (over NFS) to a NAS (also
over NFS).

As the hard drive I was ripping to was small, I changed to having the ripped
iso's on another NAS's hard drive, over NFS. So I had 2 machines ripping
from local DVD drives directly to a NFS drive. On one of the machines I
noticed it would every now and then "freeze" (become unresponsive but things
like the netspeed applet would continue just fine) for a little while,
always while the netspeed monitor read high speeds, until the speeds slowed
down and then it would start responding again. For this reason I changed to
ripping to local hard drive, and then after the ripping process, transfer
the file to the NFS drive. This was working ok, but on the machine that had
been freezing, it made the problem worse. While ripping, everything was just
fine, no freezes. When I tried to transfer the file, I would then get
freezes for even longer than last time. The end result is that the file does
transfer fine, it would appear that it attempts to send it over the network
too fast for the NAS and in the process freezes up the computer. The load
goes up, but the memory usage doesn't change.
I've tried changing the wsize and rsize values. I've halved them from what
the server auto negotiated and even that doesn't work. If I rsync or scp the
files then I don't have any of the problems, but it does go a lot slower
than NFS. (Even with the freezes).
I've done some googling and reading of NFS network issues and tried to find
what I can do to fix it. The computer and the NAS are both on a Gigabit
switch which appears to be fine.
Attempting to transfer to the other NAS also exhibits the same issue.

Any ideas to get this working welcomed. Reads from the NAS's work fine,
reaching 20MB/s and averaging around 18MB/s from the slower NAS (max), and
reaching 33MB/s and averaging 30MB/s from the faster NAS (korby, the main
one I'm trying to write big files too). Korby is a QNAP TS-410, reading and
writing to a 2TB WD drive (not in RAID). Max is a WD My Book World Edition
1TB WD drive also not in RAID.

Below is some of the "debug" info to try and help with working out the
issue. ifconfig on the client doesn't show any errors. ifconfig on the
server does show errors.

# ifconfig (server)
eth0      Link encap:Ethernet  HWaddr 00:08:9B:BD:3E:8A
          inet addr:  Bcast:  Mask:
          RX packets:134427956 errors:31444 dropped:31444 overruns:0 frame:0
          TX packets:69530742 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1457307119 (1.3 GiB)  TX bytes:3046433619 (2.8 GiB)

max:/nfs/Media /mnt/DVD_Encode nfs
0 0
korby:/share/HDD_DATA/DVD_rip /mnt/DVD_rip nfs
0 0

$ nfsstat -o net
Server packet stats:
packets    udp        tcp        tcpconn
452217     3          452189     15

Client packet stats:
packets    udp        tcp        tcpconn
0          0          0          0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20100926/e1db4fe9/attachment.html>

More information about the plug mailing list