[plug] dmraid vs mdadm

Alexander Hartner alex at j2anywhere.com
Sun Mar 4 18:04:12 WST 2012

Got it all working. Thanks for all your help

I put together detailed instructions for Gentoo here :


Have fun

On 04/03/2012, at 16:12 , Tim White wrote:

> On 03/03/12 22:54, Alexander Hartner wrote:
>> Hi Tim
>> Thanks for your post. I tried this several times now, but everytime I boot of the Live CD I get md125 again. I have't been able to boot of hard drive as I keep on getting a kernel panic on boot up. I suspect the panic is caused by the kernel also not being able to find the correct md devices. I tried running the commands 
>>  mdadm -S /dev/md125
>>  mdadm -A /dev/md1 --update=super-minor
>> But they didn't fix the issue. Still on every reboot from LiveCD I get back to md125.
> This is due to the LiveCD not "knowing" about the array so it mounts it as md125 etc. (Its the auto assembling of the array that is the problem). The update super-minor stuff will assign it the correct "name", but it's still up to the initramfs to mount it correctly, and it uses mdadm.conf to know which number it should be. So after doing an update super-minor, you'll need to chroot into the new install, and update the mdadm.conf file AND the same file in the initramfs (see Brian's post for some info on that). There is a command to auto create the mdadm.conf file, but you'll need to google for that.
>> <snip>
>> and a reboot, fdisk now reports that the partition table for mdX is not valid. 
>> Disk /dev/md127: 995.6 GB, 995640344576 bytes
>> 2 heads, 4 sectors/track, 243076256 cylinders, total 1944610048 sectors
>> Units = sectors of 1 * 512 = 512 bytes
>> Sector size (logical/physical): 512 bytes / 4096 bytes
>> I/O size (minimum/optimal): 4096 bytes / 4096 bytes
>> Disk identifier: 0x00000000
>> Disk /dev/md127 doesn't contain a valid partition table
> There shouldn't be partitions on the raid device (/dev/mdX). The partitions should be on the physical disk (/dev/sdX or /dev/hdX) and essentially /dev/mdX is a partition. You /can/ put partitions on top     of the raid device, same as any other block device, but it's not the recommended way (AFAIK).
> <snip>
>> I wonder why it is not picking up the partition table I created. 
> Try fdisk /dev/sda
>> I am using Gentoo for this as I really like it. It makes things a little bit more complicated but generally they work, well at least until now they did. 
> I've used Gentoo a long time ago, but never with raid, sorry.
> Hopefully this, with Brians post and some more googleing will help you get running!
> Tim
> _______________________________________________
> PLUG discussion list: plug at plug.org.au
> http://lists.plug.org.au/mailman/listinfo/plug
> Committee e-mail: committee at plug.org.au
> PLUG Membership: http://www.plug.org.au/membership

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20120304/c603f5fe/attachment.html>

More information about the plug mailing list