[plug] Bigpong ADSL (problem & solution)

Matt Kemner zombie at wasp.net.au
Fri Jun 1 12:58:16 WST 2001

Hi All

I set up my first ADSL connection last night (for a customer, not my own
unfortunately) and was having major problems getting it to connect - it
kept telling me the PAP Authentication failed even though I verified the
password was correct (worked under Windoze)

I tried everything I could think of (quotes around the username, around
the password, trying with and without the @bigpond suffix, etc etc) and
even a websearch didn't give me any clues, which was odd because I would
have thought someone would have come across the same problem.

The solution (2 hours later) was to add the username/password pair to
chap-secrets as well as pap-secrets.  I have no idea why that fixed it,
but it did.  I thought I'd mention this here in case anyone else
struggles with the same problem.

It may have had something to do with the way the machine was set up.
It started it's life as a hamm machine and was upgraded via slink to
potato over the past few years to keep it up-to-date.

I recently changed the sources.list to woody and used that to install the
latest pppoe software, so I could use the MTU CLAMP hack.

Speaking of which, for those curious how to activate that - you need to
edit /etc/ppp/peers/dsl-provider and to the end of the pppoe options add
" -m 1412"

 - Matt

More information about the plug mailing list