[plug] cdrecord - mmap error

Nigel Duff peregrin at iinet.net.au
Wed Jun 13 00:13:32 WST 2001

On Tue, Jun 12, 2001 at 04:26:59PM +0800, Adam Davin wrote:
> Recently (since a debian dist u/g to woody) If I have tried to burn a cdrom 
> i get an error:
> cdrecord: Invalid arguement. Cannot get mmap for 4198400 Bytes on /dev/zero


> I have tried recompiling the kernel ( as specified in the cd writing howto 
> ) however it *did* work with this kernel previous to the upgrade.


> I am using a 2.2.18pre21 kernel on woody ( just did a u/g last night but 
> same problem)
> cdrecord v 1.10a18

Hi Adam,

I had a similar problem. I thought i found the reason on the cdrecord
web site, but having just scoured the site I can't find the reference.

It went something like this. The precompile binary for cdrecord v 1.10
was compiled on a 2.4 kernel. This kernel supports mmap. Older kernels
(eg: 2.2.*) doesn't handle mmap correctly. Looking at some other problems
on cdrecord's site, hand compiling cdrecord v1.10 by hand might fix it.
I just used the stable deb package (which breaks xcdroast on upgraded

Ahh, and just as i finish i find this 


So it looks like it will work if you compile cdrecord yourself.


More information about the plug mailing list