[plug] rooted routing :(

russ powers rpowersau at yahoo.com
Thu Apr 29 09:53:45 WST 2004

--- bob <bob at fots.org.au> wrote: 
> Well I'm obviously missing a piece of the puzzle with regard to routing and 
> What I can't even get going is 
> 	ADSL 
> 	|
> 	eth1 (192.168.1.x)
> Gateway/firewall
> 	eth0 (192.168.0.x)
> 	|
> hosts on LAN

I had this problem. 

What I had to do was set eth1 to use dhcp, not a static ip. And make the lan
192.168.1.x (because the modem defaults to 192.18.0.X when the line is dead).
This is with a DSL-300.

> although I can talk to the ADSL config web server I can't seem to route 
> stuff out through eth1. I _thought_ it was as easy as - on the 
> Gateway/firewal - del the default gw route (ppp0) add the ADSL box's IP as 
> a host route and then add eth1 as the new default gw... apparently not :(.
> I had a theory it might have been the iptables fw... nope. I briefly cleared 
> it and still no show.
> Adding a route to 192.168.1.x to hosts on LAN and setting that as its 
> default GW appears to work for a while then fails (is this a problem with 
> multiple paths to the ADSL box? ) and does not achieve what I want in any 
> case.
> Attempts to look back into my network on the ports I have routed on the ADSL 
> box to the Gateway/firewall - from spark - gets "Unable to connect to 
> remote host: Connection refused". (even with the fw down)
> I have tried everything I can think of and read so much I am becoming even 
> more confused as to how to proceed - I would very much appreciate some 
> assistance in sorting this out.
> Thanks.
> -- 
> You can't cheat the phone company.
> _______________________________________________
> PLUG discussion list: plug at plug.linux.org.au
> http://mail.plug.linux.org.au/cgi-bin/mailman/listinfo/plug
> Committee e-mail: committee at plug.linux.org.au 

Best Regards,

Find local movie times and trailers on Yahoo! Movies.

More information about the plug mailing list