[plug] Failed Debian system upgrade

Bret Busby bret at busby.net
Sat Feb 24 00:05:50 WST 2007

Hello again, everyone.

I previously encountered some problems in trying to upgrade our 
mailserver after a power blackout corrupted it.

I posted a query to the list about it, and, amongst the responses that 
I got, was a suggestion to try apt-get dist-upgrade.

So, I have just done an apt-get update, and tried to do an apt-get dist 

The result is below.

mailserver:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages will be REMOVED:
   libnewt0.51 netkit-inetd
The following NEW packages will be installed:
   debian-archive-keyring gpgv iputils-ping libdb4.4 libdevmapper1.02 
libgnutls13 libnewt0.52 libpci2 libsasl2-2 libtasn1-3 mktemp 
   sysvinit-utils tasksel-data tzdata update-inetd
The following packages will be upgraded:
   adduser apt apt-utils aptitude bash bsdmainutils bsdutils 
console-common console-data console-tools coreutils cpio cron debconf 
debconf-i18n debianutils
   dhcp-client dmidecode dpkg dselect e2fslibs e2fsprogs fdutils 
fetchmail fileutils findutils gcc-3.3-base gcc-4.1-base gettext-base 
gnupg grep groff-base
   gzip hostname ifupdown info initscripts iptables klogd libacl1 
libblkid1 libbz2-1.0 libc6 libcomerr2 libconsole libdb3 libdb4.2 
libdb4.3 libgcc1
   libgcrypt11 libgdbm3 libgpg-error0 libkrb53 libldap2 libncurses5 
libncursesw5 libopencdk8 libpam-modules libpam-runtime libpam0g 
libpcap0.8 libpcre3
   libpopt0 libreadline5 libsasl2 libselinux1 libsepol1 
libsigc++-2.0-0c2a libslang2 libss2 libssl0.9.7 libssl0.9.8 
libstdc++2.10-glibc2.2 libstdc++5
   libstdc++6 libtext-charwidth-perl libtext-iconv-perl 
libtext-wrapi18n-perl libusb-0.1-4 libuuid1 libwrap0 lilo login 
logrotate lsb-base lynx makedev
   man-db manpages mbr modconf modutils mount nano ncurses-base 
ncurses-bin netbase netkit-ping nvi openssh-client openssh-server 
openssl passwd pciutils
   perl-base postfix ppp pppconfig pppoe pppoeconf procmail procps psmisc 
readline-common sed shellutils ssh ssl-cert sysklogd syslinux sysv-rc 
sysvinit tar
   tasksel tcpd telnet telnetd textutils util-linux wget whiptail zlib1g
132 upgraded, 16 newly installed, 2 to remove and 0 not upgraded.
Need to get 0B/52.6MB of archives.
After unpacking 11.2MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
   tzdata libc6 libslang2 whiptail libnewt0.52 libpopt0 perl-base 
libtext-iconv-perl libtext-charwidth-perl libtext-wrapi18n-perl 
debconf-i18n debconf sed
   ncurses-bin lsb-base ifupdown libwrap0 netbase update-inetd tcpd 
openbsd-inetd netkit-ping iputils-ping mktemp debianutils bash bsdutils 
   libselinux1 coreutils dpkg e2fslibs e2fsprogs findutils grep gzip 
hostname libdb4.3 libpam-runtime libpam0g libpam-modules login mount 
   sysvinit tar util-linux libncurses5 ncurses-base textutils 
console-data console-tools libconsole console-common fileutils 
shellutils gcc-4.1-base libgcc1
   libstdc++6 readline-common libreadline5 libusb-0.1-4 zlib1g gpgv 
libbz2-1.0 libgpg-error0 libgcrypt11 libopencdk8 libtasn1-3 libgnutls13 
   passwd adduser openssl ssl-cert postfix libdb4.2 libsasl2-2 libsasl2 
libldap2 makedev gnupg debian-archive-keyring apt initscripts libacl1
   libdevmapper1.02 libblkid1 libcomerr2 libss2 libuuid1 sysv-rc libdb4.4 
apt-utils libncursesw5 libsigc++-2.0-0c2a aptitude bsdmainutils cpio 
cron dmidecode
   groff-base info iptables sysklogd klogd libgdbm3 logrotate man-db 
manpages nano tasksel tasksel-data wget dselect procps gettext-base 
libkrb53 libpcre3
   openssh-server openssh-client pciutils libpci2 procmail telnet fdutils 
fetchmail gcc-3.3-base libdb3 libpcap0.8 libstdc++2.10-glibc2.2 
libstdc++5 mbr lilo
   lynx modutils modconf nvi ppp pppconfig pppoe pppoeconf psmisc 
syslinux telnetd dhcp-client libssl0.9.7 ssh
Install these packages without verification [y/N]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: parse error, in file `/var/lib/dpkg/available' near line 46359 
package `enlightenment-theme-brushedmetal':
  invalid package name (may not be empty string)
E: Sub-process /usr/bin/dpkg returned an error code (2)

The apt-get dist-upgrade apparently failed, due apparently to this 
brushed metal theme thing. (Plurry unenlightened "enlightenment"!)

We do not have any GUI installed on the computer, as far as I am aware, 
as it is a basic installation, to run postfix, procmail, fetchmail, and 
not alot more. We once (or twice) tried to get SQWebmail running on it, 
with postfix, but couldn't, so reverted to the previous-named three 
email utilities, without SQWebmail.

How do I overcome this issue of the dpkg parse error, relating to the 
brushed metal thing, so that I can upgrade the system and (try to) get 
it working properly again?

At present, fetchmail and postfix seem to run, for the most part, but 
fetchmail will not operate as a daemon since the power blackout (and, 
the system should be updated regularly, anyway).

Thanks in anticipation.

Bret Busby
West Australia

"So once you do know what the question actually is,
  you'll know what the answer means."
- Deep Thought,
   Chapter 28 of Book 1 of
   "The Hitchhiker's Guide to the Galaxy:
   A Trilogy In Four Parts",
   written by Douglas Adams,
   published by Pan Books, 1992


More information about the plug mailing list