[plug] Ubuntu 6.06 installation/address resolution - update.

Dave Dartnall darts at dialix.com.au
Mon Jan 15 18:16:29 WST 2007

Carl Gherardi wrote:
> On 1/11/07, Dave Dartnall <darts at dialix.com.au> wrote:
>> Timothy White wrote:
>> > I think if you add the following, replacing #.#.#.# with your ISP's
>> > DNS servers
Timothy was on the right track, but when I first tried this I messed up the
 DNS server address and consequently lost my way!

 >> There are a couple of questions nagging at me:
 >>  While it would be good to at least get ubuntu running properly (and
 >> please don't give up on me about that), am I right in my assumption
 >> that internet access is being unsuccessfully attempted during the
 >> installationprocess? And if so, getting the system  up afterwards is
 >> not solving the real problem? In other words, could it relate
 >> to a faulty adsl modem?
 >> No, that can't be right - the other three systems work fine.
 >> Evolution could be made to work by entering the ip addresses ot the pop
 >> and smtp servers but Synaptic Package manager is the bugbear

>> ...
>> Dave Dartnall
> I've missed the initial discussion, as I understand it currently:
> Several apps
> nslookup is working. (I didn't see anything in this thread using
> nslookup - thats been done right?)
> Firefox is working once ipv6 is disabled.
> Everything else (tested?) needs numeric ip addresses.
> Mandriva works.
> It has to be dns...
> A couple of ideas - the first thing I check with wierd networking
> problems is described better than I can at
> http://lwn.net/Articles/92727/ - TCP window scaling problem that bit
> lots of people including me (with 3 consecutive adsl routers).
> /proc/sys/net/ipv4/tcp_window_scaling is where that setting moved too
> now. Ubuntu defaults to 1.
> It doesn't sound like your problem (numeric/firefox working), but the
> distribution network setup defaults may be different.
> I might try sticking the other network card back in the box and test
> the other nic.
tried that - no go!
> I've had 3 separate problems with ADSL routers recently running some
> gateway protocol for 'adsl autoconfig' under both windows and linux.
> Every case was solved by manually configuring the adsl dhcp server to
> server up your isp's dns servers instead of the routers dns
> forwarding.
> Otherwise Synaptic and Evolution are Gnome apps, is your home
> directory 'fresh' with gnome settings? or have you maintained it from
> a previous installation.
Yes, a clean new installation
> Carl G
> NB: Do you have a son/brother that played cricket for Thornlie in 
> juniors?
Stephen Dartnall may have played cricket for Thornlie in Juniors. He 
lives in that vicinity and is now a pretty handy amateur golfer. He's 
the grandson of an uncle of mine - not sure what official relationship 
that is.

Thank you Carl, Timothy, Tomasz, William and Sol who all took the 
trouble to help. The  'prepend' statement added in 
/etc/dhcp3/dhclient.conf  was the answer, and to make sure, I used the 
OpenDns addresses. No doubt the cheap NB5 Netcomm modem was the problem, 
and I was unable to find out how to hard code the addresses into it. No 
problem tho' the other systems still work OK, and that'll do for the 
time being.
I will buy a new ADSL modem with a switch port for connecting my wife's 
computer in addition to my own, instead of having a separate (8 port 
overkill) switch, which will make an 8-port netgear switch and a groggy 
Netcomm modem available for anyone on the list that wants them...
Some advice here about what to buy would be appreciated.

regards and thanks again
Dave D

More information about the plug mailing list