[plug] wireless card not recognised at boot

Gavin Chester gavin.chester at gmail.com
Sun Feb 3 22:39:05 WST 2008

Hi pluggers,

I have frustrating wireless problems with acer aspire 3620 with atheros
wireless 'AR5005G 802.11abg NIC' built-in. Basically, it doesn't start
at boot time unless the planets are aligned in some particular fashion.

I had always assumed it was because I wasn't in the presence of a
wireless hotspot, being completely inexperienced with wireless before
now. I did all the usual things, ie., googling to understand the problem
before realising I needed to install madwifi for the atheros chipset
(dah!). So, for a while now I have madwifi (v. and also the
madwifi kernel modules (madwifi-kmp-default). This worked straightaway
next time I was on campus with full wireless coverage. Trouble is it is
totally unpredictable whether wireless will start. Sometimes numerous
reboots will get success, but more often not.

Now I have a combo adsl wireless router at home and am wanting to solve
the problem more urgently.

Hardware info report (below) shows that the system knows it's there, so
why is it so erratic to the point where it is non-functioning? 

I have no idea where to start. What tests should I perform? All help
kindly received :-)

So far I have gone thru' my distro hardware setup (yast on suse) and the
card is recognised and (hopefully) configured. I have also done this
basic stuff:    

# /sbin/ifup ath0
Interface ath0 is not available
/sbin/ifup eth1
Interface eth1 is not available

(tried the second one because eth0 is the wired nic)

This is the hardware info for the card:

  53: udi = '/org/freedesktop/Hal/devices/pci_168c_1a'
  pci.product = 'AR5005G 802.11abg NIC'
  pci.subsys_vendor = 'AMBIT Microsystem Corp.'
  linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:0b.0'
  info.bus = 'pci'
  pci.device_protocol = 0 (0x0)
  info.udi = '/org/freedesktop/Hal/devices/pci_168c_1a'
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0'
  pci.subsys_product_id = 1048 (0x418)
  linux.subsystem = 'pci'
  info.vendor = 'Atheros Communications, Inc.'
  pci.product_id = 26 (0x1a)
  pci.vendor = 'Atheros Communications, Inc.'
  info.product = 'AR5005G 802.11abg NIC'
  pci.subsys_product = 'Unknown (0x0418)'
  linux.hotplug_type = 2 (0x2)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0'
  pci.vendor_id = 5772 (0x168c)
  info.parent = '/org/freedesktop/Hal/devices/computer'
  pci.subsys_vendor_id = 5224 (0x1468)
  pci.device_class = 2 (0x2)
  pci.device_subclass = 0 (0x0)


More information about the plug mailing list