[plug] rrdtool

Anthony Woods anthony at monkey.id.au
Sat May 10 18:12:50 WST 2008

On Sat, 2008-05-10 at 17:46 +0800, Peter Sutter wrote:
> Anybody using rrdtool?
> I have to graphically display some historical data going back to 1970.
> I try to use the the timestamp of the first sample when using rrdcreate.
> I assume that for the first datapoint on 1970-01-03 15:03:56 I would specify 
> 198236 as the timestamp, as the man pages say the following:
> --start│-b start time (default: now - 10s)
>                Specifies the time in seconds since 1970-01-01 UTC when the 
> first value should be added to the RRD. RRDtool
>                will not accept any data timed before or at the time specified.
> yet I get the following:
> rrdtool create /tmp/clutch_graph.rrd --start 198236 --step 10800 
> DS:HAWKINS-711:GAUGE:21600:U:U RRA:AVERAGE:0.5:1:1440
> ERROR: start time: did you really mean month 198236?
> Where does this month business come from? I specified an absolute time in 
> seconds since 1970-01-01
> Any clues ?
> Peter
I use rrdtool regularly, but have never tried creating an archive for
data so far in the past.

I just tried to create an archive with your time requirements, and it
looks like it is not possible.  Instead of using an epoch time for the
start time i used an "at style" time string.

# rrdtool create test.rrd --start "15:00 03/01/70" --start 10800
DS:HAWKINS-711:GAUGE:21600:U:U RRA:AVERAGE:0.5:1:1440
ERROR: the first entry to the RRD should be after 1980


Anthony Woods.

More information about the plug mailing list