[plug] uvcvideo module for logitech quickcam pro 9000 - conclusion.

David Dartnall darts at dialix.com.au
Fri May 16 14:05:59 WST 2008

Brad Campbell wrote:
> David Dartnall wrote:
>>> Woah woah woah.. I just re-read what you posted. Did you upgrade 
>>> this machine from 7.10 by any chance? If you are running 
>>> 2.6.22-14-386 as the makefile is requesting then you are running an 
>>> old kernel and there is no way it will find the module you are 
>>> trying to install!
>> uname -r says: Linux localhost 2.6.22-14-386 #1 Tue Feb 12 07:12:19 
>> UTC 2008 i686 GNU/Linux
>> Upgrade was from 7.1 Gutsy - the most recent?
>> modprobe uvcvideo says: FATAL: Module uvcvideo not found.
>> And I'm sorry folks, I've had it for the day - off to bed to read the 
>> latest LINUX JOURNAL just arrived.
> Ok, you are using your old gutsy kernel! That would explain loads.
> try this
> sudo apt-get install linux-image-generic
> and then reboot. Make *sure* you select
> "Ubuntu 8.04, kernel 2.6.24-16-generic" at the Grub prompt (you may 
> have to hit (esc) to get the boot options up)
> You are running an old kernel and you really need to be running the 
> latest and greatest.
> once you boot into 2.6.14-16 you should be able to remove the old 
> kernel with
> sudo apt-get remove linux-image-2.6.22-14-386
> What *I'd* do is fire up synaptic and do a search on "linux-image" .. 
> and uninstall all the images older than 2.6.24-26-generic (do NOT 
> uninstall linux-image-generic).. that process will also remove them 
> from your grub menu list and simplify things a bit for you.
> Brad
Thank you Brad, you pointed me in the right direction, and if my system 
had been as you assumed it would have been a simple matter.
Installation of linux-image-generic did not work - it ended up in / 
instead of /boot and when I tried to access /boot all I got was a blenk 
Panic. A check on fstab revealed no entry for /boot so I fixed that and 
then through Synaptic as suggested, deleted all the old images and added 
linux-image-generic again. On reboot the boot options had not changed 
and 2.6.24-26-generic did not appear. /boot now looked ok and 
update-grub  had produced what I thought was a satisfactory menu.lst. 
Finally the penny dropped! All these problems from an installation of 
Ububtu Studio couple of months ago which apparently removed the fstab 
reference to  /boot and set up it's own  version of grub's menu.lst 
which controlled the whole boot process.
Boot into Studio and fix it from that end solved the problem.
But it took me a long time!
Dave Dartnall

More information about the plug mailing list