[plug] Cannot load eth0 on boot or after bootup

Keith Bawden keith at bawdo.com
Mon Sep 14 09:16:57 WST 2009

On Mon, Sep 7, 2009 at 18:07, Jon Miller<jlmiller at mmtnetworks.com.au> wrote:
> I have a Debian v 4 gateway server that only run a firewall and exim4 mail.
> This morning out of the blue both NIC’s failed to load on reboot.

Was this reboot after some kind of update/upgrade? In particular involving udev.

>What I
> get now is device not found.  If I run lspci I can see both nNic information
> and in dmesg I can see both Nic as eth0 and eth1.

Have you tried not using ifup and simply using ifconfig. Try ifconfig
-a to see if the cards do appear. They might be appearing as something
like eth2 and eth3... Also, take a stroll through the output of dmesg
and your system log files for possibly more insight on the problem.

Without more info I'm taking a wild guess here but here goes... Your
udev rules may have been replaced, removed or altered in some way.

Look for and inspect the contents of any udev related rules for
network interfaces. Possibly:


Mine contains a couple of lines like the following that ensure
interfaces with certain mac addresses always appear as ethn. e.g.

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:16:3e:6d:e8:e3", ATTR{type}=="1", KERNEL=="eth*",

Commenting out all such entries and rebooting can lead to the symptoms
you are seeing.

I might be totally off the mark here, but without more info this is my guess.

Regards, Keith

More information about the plug mailing list