[plug] GLX, Nvidia on Debian system

Shanon autobot at iinet.net.au
Tue Dec 6 11:39:58 WST 2005

HI gavan

Obviously 3d acceleration is failing, most likely that the module it compiled
for your kernel during installation cannot be loaded into your kernel for some
reason - X tries to insert it during start up.  Did you also compile your own

Try what the other guy said - get the re-released driver to see if that works.

Other things to help you:
- Could be AGP problem if its an agp card. I am unsure if the driver from Nvidia
gives you a nvidia-agp module, but for mine i think I used some agp module for
my motherboard chipset. My modules are


in that order.

Try insmod 'agpgart', then insmod '<your MB chipset>-agp', the loading X.
other mb chipsets are via-agp, intel-agp etc..

- You'll know it works when X starts with GLX loaded.  Once X starts you can
confirm by typing 'cat /proc/driver/nvidia/agp/status' the output on mine is:
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Disabled
SBA:             Enabled

- Your resolution looks a bit funny, but I dont think that changes anything. You
could try to change that to 800x600 just to start off, if you've tried
everything else.


Quoting Gavan Blunt <gavan at iinet.net.au>:

> Hi all.
> I've recently downloaded & run the installer from nvidia and it has 
> almost, but not quite, worked.  I'm running the 2.6.14 kernel in Debian 
> unstable, and my problem is related to the glx component.  In my 
> xorg.conf, if I add the Load "glx" line to the modules section, X fails 
> to load with a:
> Fatal server error:
> Caught signal 11.  Server aborting.
> The relevant section in the Xorg.0.log (as far as I can tell) is:
> (II) NVIDIA(0): Setting mode "1152x864"
> (II) Loading extension NV-GLX
> (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
> (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
> (**) NVIDIA(0): DPMS enabled
> (EE) NVIDIA(0): Failed to load GLX
> (==) RandR enabled
> If I remove the Load "glx" line X loads fine, but without the glx 
> extensions (obviously). The relevant part of xdpyinfo is:
> number of extensions:    33
>     Composite
>     DAMAGE
>     DPMS
>     Extended-Visual-Information
>     FontCache
>     LBX
>     MIT-SHM
>     NV-GLX
>     NV-GLX
>     RANDR
>     RECORD
>     RENDER
>     SHAPE
>     SYNC
>     TOG-CUP
>     X-Resource
>     XC-MISC
>     XFIXES
>     XFree86-Bigfont
>     XFree86-DGA
>     XFree86-Misc
>     XFree86-VidModeExtension
>     XInputExtension
>     XTEST
>     XVideo
> default screen number:    0
> number of screens:    1
> So basically my question is this: does anyone know why I can't start X 
> with the load "glx" line in my xorg.conf?
> Gavan Blunt.
> _______________________________________________
> PLUG discussion list: plug at plug.org.au
> http://www.plug.org.au/mailman/listinfo/plug
> Committee e-mail: committee at plug.linux.org.au

There are only 10 types of people in this world: those who understand binary and
those who don't.

More information about the plug mailing list