[plug] still trying to write to cdrom

Dem Nisbet dnisbet at webace.com.au
Mon Dec 3 02:14:46 WST 2007

A few months back I wrote about being unable to write to cdrom with
Fedora Core 3. I received some helpful replies, and wrote to thank
everyone, but my isp flagged my email as spam due to some bungle at
their end. This is all fixed, so I can say thanks to all, but the
problem remains.

I've used the advice, and done some checking, and I'm 99% certain that
it's because I don't have a scsi drive, and I need to turn on scsi
emulation in the kernel. I have tried to do this in various ways, but
had no luck. I used advice from Hendrik, who suggested altering
grub.conf, but I don't quite know what to add, since it isn't like the
technique described in my book (based on an earlier version of redhat).
I also tried editing /etc/lilo.conf, as suggested in my Linux book, but
it said that that alone wasn't enough, and you had to get into the
kernel and turn scsi emulation on there as well.

Here is my current /etc/grub.conf file. It appears to be the complete

title Fedora Core (2.6.9-1.667)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00
rhgb quiet
        initrd /initrd-2.6.9-1.667.img
=======================end of file=================================
Also, here is my lilo.conf.anaconda file, which I updated as per the
book (Red Hat Linux Bible by Christopher Negus, with RH 6.1 on cdroms).
Note the book says it's /etc/lilo.conf, without the "anaconda" bit, but
it is clearly the same file. The book said this is to be done on top of
allowing scsi emulation, and the purpose of updating the current file is
to make sure lilo turns on scsi emulation at startup. Note that I
detected that hdb is the cdrom, or at least I'm fairly certain of this.
I added the line append="hdb=ide-scsi" myself, as instructed by the


        append="rhgb quiet"
====================end of file==========================

I need to copy the files to cd before I can upgrade, because I don't
want to wipe any data. I assume there are ways to upgrade without wiping
everything, but I expect there's a risk of losing the files.

Can anyone tell me how to sort this out, so the kernel is configured for
scsi emulation, and also to make sure this is enabled at startup? I can
use my initiative once I get started, but I do need some help getting it
going. Alternatively, can anyone tell me a likely command to mount a usb
flash drive? Again, with that pointer, I'll probably be able to figure
out any further hitches.

Dem Nisbet.

More information about the plug mailing list