[plug] ubuntu install on netbook fails to create file system

Onno Benschop onno at itmaze.com.au
Thu Jan 5 06:20:20 WST 2012

I'll preface my response with: "I'm guessing..."

Your upgrade/installation of 11.10 should be completely independent of the
/home partition, which is precisely why people opt to make it a separate
partition in the first place. Worst case scenario is that you do an
installation without mounting the /home partition, boot into single-user
mode, empty the newly created /home directory and update your fstab to
mount /home as expected.

I am unsure why you're restructuring the partition table, in my experience
this is a pretty good way to loose all your data unless you know precisely
what you're doing and why. I'd be silly to assume that you have a full
backup of your /home partition, but who knows, perhaps I'm lucky today - if
you do have such a backup - good for you! Install or upgrade to 11.10, then
create a /home partition, then restore from backup.

As I said, I'm guessing. You might have additional information that changes
my comments slightly, or completely; I cannot tell from my side of the

Good Luck, sounds like you might need it :|


On 4 January 2012 15:22, Gavin Chester <gavin.chester at gmail.com> wrote:

> Hi, I've got hold of an older acer aspire netbook with 160gb harddrive and
> winxp. I successfully shrunk the xp partition, preserving the rescue
> partition, and installed ubuntu 10.10 netbook release. I had to use a
> bootable thumbdrive for this, of course. Everything worked just peachy.
> In the process of that first install, I elected to encrypt the /home on an
> extended partition. I fear this may be the root of the problem.
> Now I'm trying to repeat the process by upgrading with ubuntu 11.10 and it
> balks at the stage of writing the file structure, saying that it is unable
> to create the ext4fs on the root partition. I have tried restructuring the
> partition table differently, and even tried ext3fs, but always borks at the
> same point. And, now that the partition table has been altered (without a
> filesystem written) grub complains that it can't find a file system.
> btw: the installation media is fine - I've used it for an install on
> another netbook the same day.
> Any clue whether the original encrypted partition is the cause of the
> problem, and if so how to overcome it?
> Gavin
> ______________________________**_________________
> PLUG discussion list: plug at plug.org.au
> http://lists.plug.org.au/**mailman/listinfo/plug<http://lists.plug.org.au/mailman/listinfo/plug>
> Committee e-mail: committee at plug.org.au
> PLUG Membership: http://www.plug.org.au/**membership<http://www.plug.org.au/membership>

Onno Benschop

()/)/)()        ..ASCII for Onno..
|>>?            ..EBCDIC for Onno..
--- -. -. ---   ..Morse for Onno..

ITmaze   -   ABN: 56 178 057 063   -  ph: 04 1219 8888   -
onno at itmaze.com.au
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20120105/3de4a675/attachment.html>

More information about the plug mailing list