[plug] Ubuntu 12.04 headless with nvidia

Shanon Loughton autobot at iinet.net.au
Thu Jul 12 10:53:05 WST 2012

Thanks guys

Im in a situation where I can't attach a monitor at the moment at site.  I
think the answer is a properly configured xorg.conf but still not sure how
in 12.04.

Yes traditional VNC doesnt need a display 0.  However Im experimenting with
TurboVNC and VirtualGL and it needs a display 0 to render GLX commands on,
then pass to display 1 which is my VNC display.

I want avoid nouveau driver for now unless I really get stuck with Nvidia
binary -  I dont think thats the problem, but rather X/gnome/unity whatever


On 10 July 2012 19:10, Scott Middleton <scott at assuretek.com.au> wrote:

> On 8 July 2012 01:20, Shanon Loughton <autobot at iinet.net.au> wrote:
>> Hi all
>> How can I run a desktop install headless with 12.04?  Ie no monitor
>> attached.
>> With it attached I get a display :0.0 start up. Without a monitor
>> attached, no :0.0 is available.
>> This looks good http://ubuntuforums.org/showthread.php?t=1851330&page=2dealing with EDID stuff but doesnt work for me.
> what I do with monitor attached.
> I set auto-logon for a particular user and i set the auto-logon user with
> admin privileges (so I can use sudo).
> I enable remote desktop sharing making sure I untick "require user
> permission"
> I  require a password. None of them are live but still....
> I generate an xorg.conf file. Using X -configure (off the top of my head)
> or use Brian's method. The X -configure needs to be executed in the console
> * *while lightdm is not running "lightdm stop"
> Copy the /root/xorg.conf.new to /etc/X11/xorg.conf
> reboot and test that you like the resolution, the auto logon works and the
> ability to remote VNC to the desktop. It is a good idea to actually pull
> the plug on the computer especially if you have a video card with multiple
> monitor capability. I have found that some cards need to be completely
> powered off first. My damn nvidia card is  a pain in the arse.
> Change the driver in /etc/X11/xorg.conf to "dummy"
> reboot and see if it works
> I haven't done this in 12.04 but I have a couple in 10.04
> Alternatively
> sudo apt-get install vnc4server
> I had a couple of virtual hosts with this config that were running windows
> guests. The clients needed/wanted a remote gui console. Nowadays I use vrdp.
> Scott Middleton
> Managing Director
> Linux Consultants Pty Ltd t/as AssureTek
> Email - Scott at assuretek.com.au
> Phone - 1300 551 696
> Mobile - 0400 212 724
> _______________________________________________
> PLUG discussion list: plug at plug.org.au
> http://lists.plug.org.au/mailman/listinfo/plug
> Committee e-mail: committee at plug.org.au
> PLUG Membership: http://www.plug.org.au/membership
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plug.org.au/pipermail/plug/attachments/20120712/91eacb12/attachment.html>

More information about the plug mailing list